Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

× Contact Enhanced is a contact component manager created to replace Joomla! core contacts component and add lots of advantages and new features (see Features ) and it offers many plugins and modules for several different purposes,
Product page | Documentation Page

Google map says "sorry, we have no imagery here"

1 month 1 day ago #25965 by bcraigie
Hi Douglas :-)

I wonder if you can help?

On Joomla 3.10, PHP 8.0.14 using Contact Enhanced 3.9.14 pro, on the map in Satellite view (or hybrid) it says "sorry, we have no imagery here" but of course there should be imagery there - it is Edinburgh. See attachment.

In the Javascript console, it shows
This site overrides Array.from() with an implementation that doesn't support iterables, which could cause Google Maps JavaScript API v3 to not work correctly.

Also, there's a complaint about googleapis object map iterator (see attached screenshot).

And

Google Maps JavaScript API warning: NoApiKeys developers.google.com/maps/doc...ipt/error-messages#no-api-keys

We do have API keys set up for this site and Google's api console shows no errors.

Another site using Contact Enhanced on the same versions of everything works fine. Strange.

I have uninstalled ContactEnhanced and re-installed it, but it did not help.

Have you seen this before?

Thanks

Brian
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 day ago #25966 by support
Dear Brian,

This error happens sometimes when there are no images for the selected zoom level. I don't think this is your case.

Are you using the same API keys on both sites? Can you use with the same API key for testing purposes?

Best regards,

Please Log in or Create an account to join the conversation.

1 month 1 day ago #25967 by bcraigie
Hi Douglas and thanks for your reply.

It's not a zoom level problem as there is imagery for Edinburgh at all levels - I've zoomed in and out.

The API keys are different, and restricted to their own specific site. I can try to use another key and see what happens.

I'll let you know. :-)

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback