Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

SOLVED:iRecommend Component and Plugin: email page link bug!

11 years 4 months ago #3767 by douglas
Dear Averan,

That's odd. It should've changed the URL.
The link is created in the [Joomla]/components/com_irecomend/helper/helper.php Look for the method (function) getiRecommendLink;

Did you clear the content cache?

Can you post a link so I can take a closer look?

Best regards,

Please Log in or Create an account to join the conversation.

11 years 4 months ago #3769 by averan
this is the link it is creating:
fac.consciousdev.com/component...coming+Exhibits&tmpl=component
it appears the same whether i have the sef url option selected or not.

you can see it here:
fac.consciousdev.com/harringto...llery/gallery-upcomingexhibits
it's the link/button at the top of the right column "Email"

meanwhile, i'll take a look at that file.
thanks again.

Please Log in or Create an account to join the conversation.

11 years 4 months ago #3770 by averan
I don't see anything wrong with your link code......I must have something wrong with my sef? But I don't have any conflicts with anything else on my site from an unnecessary forward slash. Very strange.

Yes, I did clear all cache on the site.

Please Log in or Create an account to join the conversation.

11 years 4 months ago #3771 by douglas
Dear Averan,

I don't think this message is related to iRecommend at all.

This is a System Message that could be generated by any extension (Component, module, plugin or template).

System messages are stored in a session variable and your template does not show the system messages, that's why you thought that it was related to iRecommend.

I tried to load your page using ja_purity fac.consciousdev.com/harringto...ingexhibits?template=ja_purity , however irecommend is not loading there because of the module position.

Have you created this template? if so, please add <jdoc:include type="message" /> somewhere before <jdoc:include type="component" />.

Sincere regards,

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback