Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

Error with Module

10 years 7 months ago #7058 by brynlewis
Hi, just installed the component and published the module. When I click on the recommend button i get the following message, any reason please?

all help appreciated, cheers Bryn


Forbidden

You don't have permission to access /component/irecommend/ on this server.

Apache Server at www.carringtoncyprus.com Port 80

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7059 by douglas
Dear Bryn,

This looks like a file permission issue.

If you do not have SSH access, please contact your host to recursively apply write permissions to your Joomla directory, or at least to
[Path to Joomla]/components/
[Path to Joomla]/administrator/components/

Even though the component directory might be writable the sub-directories might not be.

All the best,

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7068 by brynlewis
Hi,

I have reset all the permissions and asked my hosting company to double check. Everything is fine now but the issue still remains.

any other ideas why this would happen?

cheers

Bryn

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7069 by brynlewis
error message
Attachments:

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7070 by douglas
Dear Bryn,

This message is generated by the server, not the application therefore it is harder to debug.

Does it work if you have SEF disabled?

Best regards,

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7071 by brynlewis
just turned it off & on again. Still the same unfortunately

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7072 by douglas
Dear Bryn,

That's odd. It should not look for /component/irecommend it soulhd be /component/com_irecommend instead.

Can you provide access so I can take a look?

regards,

Please Log in or Create an account to join the conversation.

10 years 7 months ago #7073 by brynlewis
right, now to get complicated.

I have set the module to registered so I can try it out when no one else can see.

On the front page it directs to another page with SAME warning
when on the FORUM side of our site (which is private to office use) it opens a page to recommend to others but this page does nothing then afterwards.

Could this be a conflict with mootools?

Please Log in or Create an account to join the conversation.

10 years 6 months ago #7076 by brynlewis
Hi,

Just about sorted this now. I am waiting for my hosting company to get back to me. One questions, when the pop up screen opens on your site there are no scrollers and it looks clean. On mine scroller bars appear everytime and I cannot seem to edit the size to stop it happening.

any ideas?

cheers

Please Log in or Create an account to join the conversation.

10 years 6 months ago #7079 by douglas
Dear Bryn,

That's probably because your default template adds a specific width to the site.
What you can do is change the template to load on the modal window in the Module Parameters. I usually choose JA Purity.

Best regards,

Please Log in or Create an account to join the conversation.

10 years 6 months ago #7081 by brynlewis
great tip, all sorted now. Can I thank you for your excellent support. I will recommend your services to many people.

http://www.carringtoncyprus.com/

For a point of note, the problem on the front page was sorted yesterday. If anyone else has this problem in the future, this was the message I received.

Hi Bryn,

It was mod_security rule blocking that page. Should be OK now.

--
PlugSocket Support

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback