Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

module not working

7 years 5 months ago #18384 by yoana_iliewa
Hello,
I'm using your module, but it is not working. Does not send e-mails and there is no message for error or something. Just redirects to homepage with no other action. You can check it at:

http://naoa.prolangs.bg/index.php/dostap-do-obshtestvena-informacia

Please help me make it work!
Best regards,
Yoana

Please Log in or Create an account to join the conversation.

7 years 5 months ago #18385 by douglas
Dear yoana_iliewa,

Which Ajax Contact and Joomla versions are you using?

Anyway, I believe the problem is because your site is loading two jQuery versions:
- One is the jQuery included in Joomla and it's up to date version 1.11.1
- The second one is a very outdated version (1.8.1), loaded by a plugin:
/plugins/system/yt/includes/admin/js/jquery.min.js

I advise to either disable this outdated plugin OR at least disable the feature to load jQuery, because it's already loaded by Joomla.

Best regards,

Please Log in or Create an account to join the conversation.

7 years 5 months ago #18390 by yoana_iliewa
Hello again,
I'm using Joomla 3.3.6. and AjaxContact 3.3.1.

The plugin that loads second jquery is a framework for the template I'm using so I can't disable it. I added an exclusion for mod_ajaxcontact in this plugin and I tried to upgrade the jquery in this framework (not sure if did successful so you can check). Not sure how to disable the whole jquery from this plugin. Can you help me do that or give you access so you can check?

Best regards,
Yoana

Please Log in or Create an account to join the conversation.

7 years 5 months ago #18391 by douglas
Dear Yoana,

You are still loading jQuery twice and /plugins/system/yt/includes/admin/js/jquery.min.js is still loading version 1.8.1.

Loading jQuery twice causes your website to load slower because it has to load the file twice and then instantiate jQuery twice.

Also, because jQuery 1.8.1 is loaded last it's taking over the previously loaded jQuery.

I understand some templates used to add their own jQuery version in Joomla 2.5, however Joomla 3.x already provides a very nice and easy way to load the most up to date jQuery version.
It also loads the noConflict() and the jquery-migrate.js which solves most problems old template might have with new jQuery code. In other words jquery-migrate.js loads all old and deprecated jQuery functions/methods and makes old scripts compatible with the latest jQuery version.


Can you please copy the above and send it to your template developer?

Best regards,

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback