Support Forum

Every time that you post a problem, PLEASE add the Joomla and the extension's versions and revisions (for example: Joomla 3.3.6, Contact Enhanced 3.3.5), PHP version and Server's Operating System. If you only manage only one site it is easier if you edit your profile and just add that information to your signature. Don't forget to add a detailed description of the problem. If possible, write down all steps to simulate the problem.

Before submitting a new post, PLEASE make sure you are running the latest version, test in different browsers (IE, FF, Chrome,..) and clear Joomla and browser's cache after every change you make.

Also, most questions are already answered in our FAQ and in iFAQ and Contact Enhanced documentation pages.

× Contact Enhanced is a contact component manager created to replace Joomla! core contacts component and add lots of advantages and new features (see Features ) and it offers many plugins and modules for several different purposes,
Product page | Documentation Page

Nothing showing in SP Page Builder

2 months 3 weeks ago #26483 by blue_Shift
The module is assigned to "any" page as it is typically accessed via menu item or loadposition. But in this case, I've assigned the module in SP Pagebuilder and have nothing to show for it - just a blank space. I just installed the most recent version of CE. Is there some configuration trigger I need? In a pinch I can load it in a modal.

J 3.9.11
SPPB 3.8.8
CE 4.2 (J3 version)

I have not tested in the J4 sandbox as the first implementation will be on the production site, still in J3 until Oct 1.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26484 by support
Dear blue_Shift,

I'm not really familiar with SP Builder, but if you are loading a module, it should work.

Contact Enhanced 4.x is for Joomla 4 only. Please make sure to install the correct Contact Enhanced version (3.10 or newer) for your Joomla version.

Best regards,

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26485 by blue_Shift
Yes - I did install the J3 version. And yes, I was adding a module via SPPB 3.8.8 (current J3 version). And no, I am not seeing a form. There are no errors in the console.

Attachments:

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26486 by blue_Shift
Could not edit the replay to add: the CE version installed from that folder is 3.10.7

(might want to fix that edit feature - it gave me a 403 error)

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26487 by support
Does the same module load correctly on the same page when loading it without SP Page Builder?

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26488 by blue_Shift
Yes.




PS, same problem in J4 / SPPB 3.8.8 (note - this version of SPPB is in a two-year end of life period).
Attachments:

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26489 by support
I see what's the problem.
SPPB needs to be able to execute Content Plugins in order to allow you to use loadcontact or loadposition syntaxes. Please contact SPPB support to find out how it's done using their extension.

Best regards,
The following user(s) said Thank You: blue_Shift

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26490 by blue_Shift
Here's what worked: I could load the custom HTML module in SPPB with "prepare content" activated, and the form appeared.

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26494 by support
I'm glad you found a workaround. If the Custom HTML module is loading, so should all other modules, including Contact Enhanced.
If the module loads correctly using the Joomla core module position it should load correctly by any software that executes the HTMLHelper::_('content.prepare',[...]) method. If you want to continue to investigate, you can ask SPPB support why a module wouldn't load using their software.

Best wishes

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #26506 by blue_Shift
Their documentation and forum commentary indicates prepare content / render plugins facility is deliberately not included in the product. I think it is because pagebuilders run outside Joomla core - I only use them for landing pages. Joomla core has some unique advantages - and I like to use them!

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago #26510 by blue_Shift
Back to square one. It works in J3... but the method does not carry over to J4 (with CE 4.2 > Joomla 4 version installed).

Also, the {loadcontact} form shortcode is not an option in J4, only an email link to the contact.

(This is submitted understanding your off-hours preferences and obligations, no reply is needed or expected before Monday)

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago #26511 by blue_Shift
I copied the shortcode from the J3 version and it works in J4. So your 'add a shortcode' option needs a way to inject the form shorcode.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum

Copyright © 2018 IdealExtensions.com. All Rights Reserved.

This site is not affiliated with or endorsed by the Joomla!™ Project. It is not supported or warranted by the Joomla!™ Project or Open Source Matters™. The Joomla!™ logo is used under a limited license granted by Open Source Matters™, the trademark holder in the United States and other countries.
We may collect your IP address and your browser's User Agent string while using our site for security reasons and deriving aggregate information (analytics). This information is retained for a minimum of 1 and a maximum of 24 months.
Feedback